Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

(Windows 10) System settings open when i open opera??

  • This seems to have worked for me: close Opera, go to C:\Users<your_user>\AppData\Roaming\Opera Software\Opera Stable (got this path from the About page), open the "Preferences" file in your text editor of choice, look for "check_default_browser", change its value from true to false, save your changes, and start Opera. I've restarted Opera several times and the Settings window didn't come up again. The value in the Preferences file switched back to true (I guess the first time I opened Opera again) but the Settings window is not coming up anymore.

  • Did not work for me alexvy86.

  • Hello Everyone, I was having the same problem, but I think I might have found a solution. From my understanding, it is something to do with the API to Windows that Opera uses to set itself as the default browser causing the issue. However, Chrome has fixed this issue with the API. Therefore, I set Chrome as the default through Windows Settings > System > Default Apps, then opened Opera and selected 'No' when asked if I wanted to set Opera as the default, and checked not to show this message again. I then closed Opera, opened Chrome, navigated to any web page, then closed Chrome. I then went back into Windows Settings and set Opera as the default, opened Opera and NO SETTING POPPED UP!!
    Hopefully this will work for you too! - Please let me know if it does and I will post the solution on other forums to help others having the same issue.
    Thanks!

    this kinda works,but i made microsoft edge and windows default mail program to default,then to set google chrome to default,then set opera to default
    also starting opera after every step to check,then closing opera again

  • jamesmcharks' solution worked perfectly for me on Windows 10 64-bit.

    THANKS!

  • I fixed this by setting Mail as my default email app.

  • Hi,

    yes i confirm the mail setting for Opera (in Windows Default APPS and in Opera settings mailto => mail.google.com) is one of the causes of this problem.

    For the main problem, a solution is also provides here: http://forums.opera.com/post/101481.

  • Same Problem, but it is a little different. When I open Opera, the settings with Default Apps open. There when I try to make Opera as my Default Browser, i click on Opera from the list of softwares but, it actually doesn't make it my default browser. When Opera is my default browser, it should show Opera icon below the Default Browser option but it actually doesn't. So I can't even make Opera as my default browser. So whenever I open Opera, the settings open with it.

    Also I cannot use the trick of making chrome or any other browser as default. So what should I do????
    Also i am not going to download Chrome any more, there are a lot of problems it caused to my new laptop which i bought 2 weeks ago, and some of them still continue. I find Opera much better than chrome and also want to make it my default software.

    Please Help

  • This seems to have worked for me: close Opera, go to C:\Users\AppData\Roaming\Opera Software\Opera Stable (got this path from the About page), open the "Preferences" file in your text editor of choice, look for "checkdefaultbrowser", change its value from true to false, save your changes, and start Opera. I've restarted Opera several times and the Settings window didn't come up again. The value in the Preferences file switched back to true (I guess the first time I opened Opera again) but the Settings window is not coming up anymore.

    Thank you SO MUCH, alexvy86! This worked immediately for me in Windows 10. This was becoming very bothersome... I appreciate your sharing more than you know. Have an awesome day!

  • Hello Everyone, I was having the same problem, but I think I might have found a solution. From my understanding, it is something to do with the API to Windows that Opera uses to set itself as the default browser causing the issue. However, Chrome has fixed this issue with the API. Therefore, I set Chrome as the default through Windows Settings > System > Default Apps, then opened Opera and selected 'No' when asked if I wanted to set Opera as the default, and checked not to show this message again. I then closed Opera, opened Chrome, navigated to any web page, then closed Chrome. I then went back into Windows Settings and set Opera as the default, opened Opera and NO SETTING POPPED UP!!
    Hopefully this will work for you too! - Please let me know if it does and I will post the solution on other forums to help others having the same issue.
    Thanks!

    Worked great for me too! (I did reset to Microsoft defaults in the Default Apps page before doing all the steps mentioned) Thanks so much!

  • So to have Opera working properly I need to download and install Chrome? Really?? Maybe I should just stick with Chrome then.
    I miss old times when Opera was a real browser and not just a Chrome skin.

  • hi there , I think I have got a solution, the same problem was with me. I just simply tried to set opera as a default app from control panel rather than making it a a default app in settings . And it just worked on . still not then go to control panel set chrome/mozilla/edge as the default app (Control Panel\Programs\Default Programs\Set Default Programs) and click "set this program as default" , when other browser is set as default then set it to opera and you are done !!! Hope it works .. Thanks

  • Thank you sarthakdadheech. That worked very well. Much better than having to install Chrome.

  • The solution of sarthakdadheech worked for me as well, thank you!

  • In Windows 10, open Settings then choose Default Apps.
    Then press Set defaults by app.
    Now choose Opera from the list on the left, and choose Opera and press Set this program as default.
    When I start Opera, Settings has disappeared.

Log in to reply