Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

(Windows 10) System settings open when i open opera??

  • Hello Everyone, I was having the same problem, but I think I might have found a solution. From my understanding, it is something to do with the API to Windows that Opera uses to set itself as the default browser causing the issue. However, Chrome has fixed this issue with the API. Therefore, I set Chrome as the default through Windows Settings > System > Default Apps, then opened Opera and selected 'No' when asked if I wanted to set Opera as the default, and checked not to show this message again. I then closed Opera, opened Chrome, navigated to any web page, then closed Chrome. I then went back into Windows Settings and set Opera as the default, opened Opera and NO SETTING POPPED UP!! 😃

    Hopefully this will work for you too! - Please let me know if it does and I will post the solution on other forums to help others having the same issue.

    Thanks!

  • Hello Everyone, I was having the same problem, but I think I might have found a solution. From my understanding, it is something to do with the API to Windows that Opera uses to set itself as the default browser causing the issue. However, Chrome has fixed this issue with the API. Therefore, I set Chrome as the default through Windows Settings > System > Default Apps, then opened Opera and selected 'No' when asked if I wanted to set Opera as the default, and checked not to show this message again. I then closed Opera, opened Chrome, navigated to any web page, then closed Chrome. I then went back into Windows Settings and set Opera as the default, opened Opera and NO SETTING POPPED UP!!
    Hopefully this will work for you too! - Please let me know if it does and I will post the solution on other forums to help others having the same issue.
    Thanks!

    This worked perfectly! Thank you so much for the tip. I followed all of the steps and I now do not have that annoying Settings page opening. Yay!

  • same trouble. please, fix it

  • Same here. Is there any fix to it?

  • Same here. Is there any fix to it?

    Have you tried the solution proposed in this topic?

  • Same here. Is there any fix to it?

    Have you tried the solution proposed in this topic?

    Yes, but it didn't work.

  • Hello Everyone, I was having the same problem, but I think I might have found a solution. From my understanding, it is something to do with the API to Windows that Opera uses to set itself as the default browser causing the issue. However, Chrome has fixed this issue with the API. Therefore, I set Chrome as the default through Windows Settings > System > Default Apps, then opened Opera and selected 'No' when asked if I wanted to set Opera as the default, and checked not to show this message again. I then closed Opera, opened Chrome, navigated to any web page, then closed Chrome. I then went back into Windows Settings and set Opera as the default, opened Opera and NO SETTING POPPED UP!!
    Hopefully this will work for you too! - Please let me know if it does and I will post the solution on other forums to help others having the same issue.
    Thanks!

    That worked for me. Thanks!

  • Now there are "control panel" and "settings" that intermingle and overlap, connecting to each other and at times contradicting.

    I think that new "settings" is unstable and, at now, classic control panel is safer.

  • I followed the proposed solution to the letter, but it doesn't work for me. Any other ideas?

  • Hello Everyone, I was having the same problem, but I think I might have found a solution. From my understanding, it is something to do with the API to Windows that Opera uses to set itself as the default browser causing the issue. However, Chrome has fixed this issue with the API. Therefore, I set Chrome as the default through Windows Settings > System > Default Apps, then opened Opera and selected 'No' when asked if I wanted to set Opera as the default, and checked not to show this message again. I then closed Opera, opened Chrome, navigated to any web page, then closed Chrome. I then went back into Windows Settings and set Opera as the default, opened Opera and NO SETTING POPPED UP!!
    Hopefully this will work for you too! - Please let me know if it does and I will post the solution on other forums to help others having the same issue.
    Thanks!

    Same problem. This works fine for me. Thank you

  • Seriously people the first answer fixed the problem for me. Thank You 'leocg' you da man.................
    RIGHT click the Start Button.
    Click Control Panel.
    Click Default Programs.
    Click Set Your Default Programs.
    Scroll to Opera Stable and Click it.
    Click Set This Program as Default - Use the selected program to open all file types and protocols it can open by default.
    Click OK and Close the Control Panel.
    Close Opera if open and then open Opera.
    Bob's your Uncle

    Thank You leocg
    Try going to control panel and set Opera as default application for everything it can handle.

  • Hello Everyone, I was having the same problem, but I think I might have found a solution. From my understanding, it is something to do with the API to Windows that Opera uses to set itself as the default browser causing the issue. However, Chrome has fixed this issue with the API. Therefore, I set Chrome as the default through Windows Settings > System > Default Apps, then opened Opera and selected 'No' when asked if I wanted to set Opera as the default, and checked not to show this message again. I then closed Opera, opened Chrome, navigated to any web page, then closed Chrome. I then went back into Windows Settings and set Opera as the default, opened Opera and NO SETTING POPPED UP!!
    Hopefully this will work for you too! - Please let me know if it does and I will post the solution on other forums to help others having the same issue.
    Thanks!

    Worked for me. Thanks!

  • Has anyone found a solution.

    I do not want Chrome (if I had Chrome I would not have Opera a far superior browser in my mind) and I have tried

    RIGHT click the Start Button. Click Control Panel. Click Default Programs. Click Set Your Default Programs. Scroll to Opera Stable and Click it. Click Set This Program as Default - Use the selected program to open all file types and protocols it can open by default. Click OK and Close the Control Panel. Close Opera if open and then open Opera.

    Bob's NOT your Uncle as this does not work.

    Will have to live with it until new version appears unless someone has another solution.

  • This seems to have worked for me: close Opera, go to C:\Users<your_user>\AppData\Roaming\Opera Software\Opera Stable (got this path from the About page), open the "Preferences" file in your text editor of choice, look for "check_default_browser", change its value from true to false, save your changes, and start Opera. I've restarted Opera several times and the Settings window didn't come up again. The value in the Preferences file switched back to true (I guess the first time I opened Opera again) but the Settings window is not coming up anymore.

  • Did not work for me alexvy86.

  • Hello Everyone, I was having the same problem, but I think I might have found a solution. From my understanding, it is something to do with the API to Windows that Opera uses to set itself as the default browser causing the issue. However, Chrome has fixed this issue with the API. Therefore, I set Chrome as the default through Windows Settings > System > Default Apps, then opened Opera and selected 'No' when asked if I wanted to set Opera as the default, and checked not to show this message again. I then closed Opera, opened Chrome, navigated to any web page, then closed Chrome. I then went back into Windows Settings and set Opera as the default, opened Opera and NO SETTING POPPED UP!!
    Hopefully this will work for you too! - Please let me know if it does and I will post the solution on other forums to help others having the same issue.
    Thanks!

    this kinda works,but i made microsoft edge and windows default mail program to default,then to set google chrome to default,then set opera to default
    also starting opera after every step to check,then closing opera again

  • jamesmcharks' solution worked perfectly for me on Windows 10 64-bit.

    THANKS!

  • I fixed this by setting Mail as my default email app.

  • Hi,

    yes i confirm the mail setting for Opera (in Windows Default APPS and in Opera settings mailto => mail.google.com) is one of the causes of this problem.

    For the main problem, a solution is also provides here: http://forums.opera.com/post/101481.

  • Same Problem, but it is a little different. When I open Opera, the settings with Default Apps open. There when I try to make Opera as my Default Browser, i click on Opera from the list of softwares but, it actually doesn't make it my default browser. When Opera is my default browser, it should show Opera icon below the Default Browser option but it actually doesn't. So I can't even make Opera as my default browser. So whenever I open Opera, the settings open with it.

    Also I cannot use the trick of making chrome or any other browser as default. So what should I do????
    Also i am not going to download Chrome any more, there are a lot of problems it caused to my new laptop which i bought 2 weeks ago, and some of them still continue. I find Opera much better than chrome and also want to make it my default software.

    Please Help

Log in to reply