Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

System Settings window opens on starting Opera

  • That fix doesn't work for me, too. У меня фикс тоже не сработал.

  • Strange because it worked for me

  • That "fix" does not work, the problem still persists.

  • Same problem. 😞

  • Same problem, really annoying!

  • Hello Everyone, I was having the same problem, but I think I might have found a solution. From my understanding, it is something to do with the API to Windows that Opera uses to set itself as the default browser causing the issue. However, Chrome has fixed this issue with the API. Therefore, I set Chrome as the default through Windows Settings > System > Default Apps, then opened Opera and selected 'No' when asked if I wanted to set Opera as the default, and checked not to show this message again. I then closed Opera, opened Chrome, navigated to any web page, then closed Chrome. I then went back into Windows Settings and set Opera as the default, opened Opera and NO SETTING POPPED UP!! 😃

    Hopefully this will work for you too! - Please let me know if it does and I will post the solution on other forums to help others having the same issue.

    Thanks!

  • I don't have chrome but I tried those same steps using both Microsoft Edge, and firefox, no dice. despite disabling the default browser check opera STILL brings up the settings window constantly.

  • Hi Weyouny, I believe you have to use Chrome, using the steps I have outlined above, as Chrome does something to fix the API problem which is effecting both Opera AND Firefox.

  • downloaded and installed chrome, tried your fix again, still doesn't work. uninstalling chrome (and possibly opera if this keeps up, so bloody annoying)

  • There is no need to use other browsers. Solution:

    1. Open Opera.
    2. In Win10 system dialog choose: default settings for all applications.
    3. Close Opera.
    4. Open Opeara. Enter Opera settings. Choose "browser" -> "Set as default browser".
    5. Now in just opened Win10 system app associations dialog choose Opera browser for web navigating.
    6. Done. Restart Opera.
  • That actually worked for me! Thanks so much! Now I just have to go fix all my other file associations back since microsoft retook over all my media files -.-

  • There is no need to use other browsers. Solution:

    1. Open Opera.
    2. In Win10 system dialog choose: default settings for all applications.
    3. Close Opera.
    4. Open Opeara. Enter Opera settings. Choose "browser" -> "Set as default browser".
    5. Now in just opened Win10 system app associations dialog choose Opera browser for web navigating.
    6. Done. Restart Opera.

    Hi I tried the instructions above but fall short when I get to No 4 I don't have the option to choose a default browser! take a look at this screen shot https://postimg.org/image/nwjmc01mf/ and tell me what I have done wrong please.

  • john164
    It means that Opera already set as default brauser. Maybe you do wrong on step 2: http://fileinfo.com/img/help/windows_10_system_settings.png "Reset to the Microsoft recommended default"

  • john164
    It means that Opera already set as default brauser. Maybe you do wrong on step 2: http://fileinfo.com/img/help/windows10system_settings.png "Reset to the Microsoft recommended default"

    Re-setting to Microsoft recommended default did the trick Thank You.

  • Hi,

    in fact the shoorfandrey's solution works very well, thanks !

    To set Opera as the default APP for Mails (in Opera settings: mailto => mail.google.com, and in Windows default APPS => Opera), when restarting Opera it doesn't work the Windows Default APPS reopened again.

    Any idea ?

  • Thanks for the help, my Windows 10 settings no longer opens when I open my browser. \m/

Log in to reply