Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera 37 won't open any pages

  • I'll have to try that, just as soon as I research how to go about doing so properly.

  • I'll have to try that, just as soon as I research how to go about doing so properly.

    Just run Opera's installer, go to Options, change the install path and on the 'install for' field choose 'Standalone installation (usb)'.

  • I did the install on USB and it doesn't load anything either. Tried running the standalone version on a different desktop PC, it didn't work there, and now the previously installed Opera on that PC no longer works. It (37) still works on my daily use PC so far. Two down, one to go, and it will be Firefox from here on, unfortunately. Been using Opera for about 15 years now.

  • Forgot to mention that Opera 12.17 still works on Win 7 32 bit. 🙂

  • I did the install on USB and it doesn't load anything either.

    Do internal pages (settings, bookmarks, plug-ins and so on) work?

  • Bookmarks are the only thing that shows up, but obviously nothing loads when you click on it. Settings, Themes, Extensions, About Opera, Speed Dial, etc., do not load.

  • If you start Opera with command line --no-sandbox, there is any difference?

  • Yes, Opera runs using that, but Windows 7 won't let me add that to the taskbar icon properties. I can only run Opera by going through the "run" feature and adding the "--no-sandbox" after the executable. Windows 8 would let me add it to the desktop icon. What gives? I don't know enough about Opera to fix it.

  • but Windows 7 won't let me add that to the taskbar icon properties

    Create a desktop shortcut, add the command line to it. Then open Opera using that short-cut and pin to task-bar.

    I guess it should work.

  • What is the danger involved in running --no-sandbox?

  • What is the danger involved in running --no-sandbox?

    Don't know.

  • Hi falfan762, I had the same issue when I was using Opera via third party such as LiberKey. When I launched Opera from the opera.exe, no the launcher provided by LiberKey everything worked fine. The only difference I noticed was that via the launcher the user profile and cache folders were not at their defaults (AppData/temp/etc...) but instead in the LiberKey folder.

    Therefore, if worried of using --no-sandbox, perhaps check what are your profile, cache, etc. folders (the ones Opera works with) and change to default. (e.g. Profile: $username$\AppData\Roaming\Opera Software\Opera Stable; Cache: $username$\AppData\Local\Opera Software\Opera Stable).

    It worked for me, hope it works for you.

  • Windows 7 and 8.1 won't let me modify the shortcut for launcher.exe or opera.exe, so Firefox it is!

  • Windows 7 and 8.1 won't let me modify the shortcut for launcher.exe or opera.exe

    Right click on launcher.exe > send to desktop. Go to desktop, right click on the short-cut and go to properties. Add the command line in the target field.

    Can't you do that?

  • Not in Win7

  • And why can't you do that in Window 7? It is a feature of Windows 7.

  • Not in Win7

    What happens when you try to do it?

  • "The name 'C:\Program Files (x86)\Opera\launcher.exe --no-sandbox' specified in the Target box is not valid. Make sure the path and file name are correct."

    Both Win 7 PCs give that error. Win 8.1 also...

  • "The name 'C:\Program Files (x86)\Opera\launcher.exe --no-sandbox' specified in the Target box is not valid. Make sure the path and file name are correct."

    Are you adding the parameter after the quoted path, like this?

    "C:\Program Files (x86)\Opera beta\launcher.exe" --no-sandbox
  • No, I entered it just as previously posted, with the parameter inside the quotation marks. I'll try as you suggest and post the results.

Log in to reply