Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera 12.18

  • So, they're messed up and not showing properly, right ??

    If so, it's something wrong with Opera itself, something with the coding if I may say "poor".

    I'll report back what I've found so far.

  • The icons are messed up here in Firefox, Qupzilla, and Opera 12.18. In Firefox, they appear as small rectangles with "FO" above "05" inside the top ones (where the stars should be) and "F1/C0" and "F0/44" in the ones half way down the page; in Opera 12.18, they appear mainly as small rectangles, some of which have "x" symbols in them. The only browsers they seem to render correctly with are chromium/Blink-based ones.

  • Regarding icons on http://www.softpedia.com/ , they are properly displayed in all the browsers I tested (Firefox, Opera 35, Chrome, Pale moon) but not Opera 12 even I fixed the issue I was having with other sites, which means the problem is with Opera 12 itself.

    .

    Now back with my issue.

    I was having windows firewall disabled using "Windows 10 Toggle Tweaker", and changed the start up mode to "Disabled" in services.

    What I did was changing the start up mode to manual but this only didn't work, I had to start the service manually after right clicking the windows firewall service.

    .

    So, enabling Windows firewall fix that, can you believe it , but I'll disable it again cause I don't like it.

    It is because of MicroShit, this happen to me before, I couldn't use Windows updates (always ended with errors and nothing updated) because firewall was disabled. Also some programs that rely on "Inno VCL Styles" wasn't working and given errors like this one http://www.softpedia.com/get/Programming/Patchers/Inno-Setup-XDELTA-Patch-Maker.shtml , and I've contacted the author and he fixed that.

    This is just bullshit of M$hit to force you use their firewall or maybe bad coding, and I guess I can say Opera 12 is not fully compatible with Windows 10 which could be expected (it's 2 years old now or so), other browsers have no problem with firewall disabled.

    Hopefully someone can find a fix for this or a workaround of some sort.

    Thank you all for your help and special thanks to @davehawley, @sgunhouse and @stng who bear with me.

  • Has anyone else noticed that Facebook is now mis-rendering in 12.18?
    The search field has dropped a line here and is now sitting on top of the first part of the main display, and everything in the bar where it should be is shifted to the left.
    Only noticed it today, it was always OK in 12.17.
    Changing the site preferences seems to make no difference.
    😕

  • Has anyone else noticed that Facebook is now mis-rendering in 12.18?

    Yeah, the search field is misplaced recently, but it also was like that in 12.17. Probably can be fixed by a custom CSS, but I haven't figured how.

  • Thanks for the updated version.

    Conspiracy theorists: They might be able to do all kinds of tracking not only through the Windows binaries, but also through the online/call-home functionality like Dragonfly and whatever home servers Opera communicates with. 🙂

  • Has anyone else noticed that Facebook is now mis-rendering in 12.18?

    Yeah, the search field is misplaced recently, but it also was like that in 12.17. Probably can be fixed by a custom CSS, but I haven't figured how.

    Strange, because I only noticed it was wrong yesterday, and I've had 12.18 installed ever since it was released.
    I certainly don't remember seeing the problem ever in 12.17.
    If it's fixable by any means that would be very good indeed!
    🙂

  • My installation of 12.18 has stopped launching Flash for one particular site, churchservices.tv. It worked fine after update from 12.17 until two mornings ago - now the page is rendered OK but there's a space where the flash popup should be. The contact person at the website says there have been no changes to the site recently.

    The flash installation is .306 ie. latest. The last time I used it successfully for the site in question, I also had a copy of Realplayer open.

    Other sites such as Youtube, and another church network mcnmedia launch the plugin OK, though the churchservices guy says they use a more recent edition of jwplayer than mcn.

    I'm running Windows Vista 32bit on an old Amilo laptop. Never had an issue with the problem site using 12.17.

    Any suggestions most gratefully received!

  • Confirmed here.
    Woks fine in all my other browsers, but as you say, no sign of the plugin loading on 12.18.
    Changing the site preferences seems to make no difference.
    😞

  • Thanks Dave, good to know it's not something on my machine.

  • It's probably something to do with the JW Player they're using.
    It doesn't produce the normal menu when right clicked that YouTube videos and others give.
    🙂

  • @winterling churchservices.tv, also twitch.tv and many many sites with weird domain prefixes :

    You need to manually download https://publicsuffix.org/list/public_suffix_list.dat
    rename it to public_domains.dat
    and copy it over to C:\Program Files\Opera x64\defaults or wherever you installed Opera 12.18.

    This is an ancient bug introduced around 12.15. Opera people first forgot to bundle this file with 12.15/.16/.17 x64 builds, and now its gone from both 12.18 x86 and x64 builds.

    Without this file for example twitch.tv wont work. It has something to do with security (Cross-Origin Resource Sharing) and without it a lot of sites javascript cant function throwing security violations.

    Other than that it appears to be a solid build. 12.17 had totally broken openssl when tls 1.1/1.2 was enabled resulting in constant crashing. This one seems stable.

    Personally I think it might of been someones personal pet project/parting gift before being laid off in face of Chinese acquisition, for which I am extremely grateful. I had nightmares about decompiling Opera in IDA and manually binary patching newer version of openssl as my last ditch effort to use this great product in face of ECSDA gaining popularity.

    @abdozaghloul

    those icons are fonts
    opera:config#UserPrefs|EnableWebfonts
    needs to be enabled, and browser needs to be able to download appropriate webfont file from the server

    btw: all of a sudden Reddit stopped working for me on opera today. I am logged in, but cant upvote, comment or even request password reset. I thought it was 12.18, but checked again on 12.17 and its the same, can someone confirm?

  • ok W T F, how do you post links with underscore ??? 😕

    again https://publicsuffix.org/list/public_suffix_list.dat

  • Yes, it's really annoying, I don't care what @joshl and others who try to justify the use of the stupid markdown system here say!
    Thanks very much for that, but the videos are still not working on churchservices.tv.
    Should this have fixed them?
    The videos on twitch.tv do seem to be working.
    🙂

  • Dave, it's not for me, it's simple. Angles, for example. 😛

  • @davehawley

    https://developer.mozilla.org/en-US/docs/Web/API/Document/hasFocus#Browser_compatibility

    opera doesnt support hasFocus, but there is non generic fix in browser.js

    if(hostname.endsWith('accounts.google.com')){
    		document.hasFocus=function(){return !document["hidden"];}
    		log('PATCH-1152, Google sign-on - fake hasFocus method');
    	}
    

    why its not generic I dont know, pretty stupid 😕

    here is a fix for you, make a file called whatever.js, put it in userjs directory:

    // ==UserScript==
    // @name blah
    // @version 0.1
    // @author Rasz_pl
    // @namespace
    // @description blah
    // @include			*churchservices.tv/*
    // ==/UserScript==
    document.hasFocus=function(){return !document["hidden"];};
    

    works like a charm, you are welcome 🙂

  • It certainly does!
    @winterling will be delighted I'm sure!
    I take it this will fix any site with the same issue, not just churchservices.tv.
    I hope spammers don't harvest your e-mail address from that code BTW!
    🙂

  • no, its only for this one site, you could change it by leaving only "*", but this is the first time I ever encountered hasFocus in ~13 years of using Opera, so I wouldnt sweat it. I would rather message admin of that site and tell him to remove it. Its in the code, but I dont think its even used, opened this site in Chrome and there is no difference between browser having focus or not = another case of clueless web designer making something non standard and broken.

  • Thanks again!
    You haven't got a fix for the Facebook search field now being mis-placed have you?!
    😃

Log in to reply