Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera 12.18

  • Email removed from here anyway ...

  • Good update... I is still usin Opera 12.18...

  • i cannot save ebay passwords anymore, there is no "save" popup after i have entered them.
    also my saved ones from before are not offered, the yellow border is missing.

    anyone same experience? can the save be triggered somehow manually?
    would be immensly annoying if i would have to enter this every time.

    rest of the sites work so far..

  • Go into the password manager, search for "ebay" and delete all the entries.
    When you next go to the site the password save should be offered again.
    Be aware that not all sites' login pages work with Opera 12's password manager now.
    🙂

  • Be aware that not all sites' login pages work with Opera 12's password manager now.

    This is often because those sites add autocomplete="off" attribute to their login forms. I've made a User JavaScript that fixes this:

    // ==UserScript==
    // @include http://stupidsite.com/login.php
    // ==/UserScript==
    
    // prevent disabling autocomplete in forms
    (function() {
        var tags = ["form", "input"];
        for (var t = 0, tag; tag = tags[t]; t++) {
            var nodes = document.getElementsByTagName(tag);
            for (var n = 0, node; node = nodes[n]; n++) {
                if (node.getAttribute("autocomplete") == "off") {
                    node.setAttribute("autocomplete", "on"); // Opera 12 doesn't support autocomplete property
                    node.parentElement.innerHTML += ""; // needed to make changes effective for form elements
                }
            }
        }
    }());
    

    Place this in a file named autocompleteOn.user.js in your User JavaScript directory (specified here, usually it's C:\Users\<username>\AppData\Roaming\Opera\Opera\userjs) and adjust the site's address in the @include line. You can add @include lines for more sites. Then enable User JavaScript. Note that most login pages use HTTPS, so for this to work you also need to enable User JavaScript on HTTPS, but then please use it with caution as suggested in the docs (at the very bottom of the page).

    EDIT: Apparently this dumb forum's software mangles Opera config links, so you need to remove the denied: prefix from them manually...

  • Just disable

    opera:config#UserPrefs|AutocompleteOffDisablesWand
  • Just disable opera:config#UserPrefs|AutocompleteOffDisablesWand

    I have this one disabled yet Wand still won't work without the User JavaScript.

  • Yes that option is un-checked for me too and has been for a long time, but I still get sites that won't prompt for their login details to be saved.
    Thanks so much again @robkaw for the userjs, I will certainly implement it!
    I assume that the double forward slash at the start of the @include line needs to be removed to make the list active?
    🙂

  • I assume that the double forward slash at the start of the @include line needs to be removed to make the list active?

    No, the double slash is needed there. UserJS uses special markers in JS comments.

  • Ah thanks, notation like that it sometimes used to mark inactive comments, so I thought I'd better check.
    If I add multiple web addresses to the script, do they each go on a new line with their own @include at the start and double forward slash at the beginning?
    🙂

  • Yes.

  • Thank you!
    🙂

  • Glad I could help. 🆙

  • Sorry to be so demanding, but I suppose you haven't also got a fix for the typing of comments on YouTube not working properly?
    You can type fine, but the space bar doesn't work (shift+space does) and the number keys at the top of the keyboard don't work either, you have to use the ones on the right hand keypad.
    All can be worked around, but it is annoying!
    🙂

  • What weird problems you have, Dave.
    When did it start?

  • @rasz, @davehawley-

    Many thanks for your excellent suggestions about my problem - sorry I didn't reply sooner; I've not been back to the forum for a while. Got frustrated and ended up using IE9 (never used it before!) with Task Manager manually setting the program priority to High and running nothing else to force the thing to perform without stuttering.

    Firefox mis-rendered, and Vivaldi had too many modules to up the priority to stop it stuttering. Never heard of Pale Moon before - must take a squint!

    Again, many thanks and I will now see if I can get Opera (which I've used since version 3 & which never stutters when running video streams) to work again - IE9 takes forever to load ....

  • I suppose you haven't also got a fix for the typing of comments on YouTube not working properly?

    Sorry, no.

  • Palemoon is the old version of Firefox. I forget what changes it was people didn't like, but with any open source project if enough people don't like something they can just take a copy of the old code and develop it themselves. Hence there's Seamonkey (Mozilla back when it still included the mail client) and now Palemoon.

  • @joshl
    Not really sure when it started, I don't make comments on YouTube very often.
    I came to do it one day a few months ago, and there was the problem!
    If others aren't seeing it I need to investigate whether it's something to do with just my setup.

    @robkaw
    No problem, just thought I would ask!
    🙂

  • Not really sure when it started, I don't make comments on YouTube very often.
    I came to do it one day a few months ago, and there was the problem!
    If others aren't seeing it I need to investigate whether it's something to do with just my setup.

    I presume it was 12.17 then?
    Well, knocking on wood :doh: no such problem with my 11 so far. Others might, not such "rejecting characters" of sorts... 😕

Log in to reply