Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Links in Opera Mail wird falsch "übersetzt"

  • Hallo derday,

    in der Tat, auf die Idee bin ich so langsam auch gekommen 😉 Das Problem scheint momentan anders nicht lösbar zu sein. Ich schau mal, wie das so geht.

    Auf jeden Fall danke fürs Mitdenken 🙂

    Gruß
    Wolfgang

  • Ich glaube allerdings, dass weniges davon zielführend ist.

    Dann glaubst du falsch. Es ist immer zielführend mögliche Fehlerquellen auszuschließen.

    Es geht (u.a.) um ein deutsches Fotoforum, von wo ich per Mail über neue Kommentare zu Bildern oder Threads informiert werde. Das ist jahrelang und bis vor kurzem völlig problemlos gegangen, nämlich solange ich Opera 12.17 hatte. Es funktioniert damit übrigens auch immer noch tadellos (ja ich konnte mich noch nicht ganz davon trennen 😉 ).
    Da ich auf Win 10 umgestiegen bin und immer mehr Websites von Opera 12.17 nur noch schlecht unterstützt werden, habe ich mich entschieden, es nunmehr mit Opera 32 und Opera Mail zu probieren. Und jetzt taucht also das Problem auf, dass die Links in den oben beschriebenen Mails, die Umlaute enthalten, offensichtlich von Opera Mail nicht richtig codiert an den Browser weitergegeben werden. Ich habe auch andere Browser (die üblichen Verdächtigen) zum Standard gemacht, um zu schauen, was passiert, aber auch dort kommt jeweils eine falsch codierte Adresse an.

    Das muss jetzt nicht die Schuld von Opera Mail sein, denn eigentlich gibts für Opera Mail nichts zum Kodieren außer die URL in der E-Mail ist kaputt.

    Daher meine starke Vermutung, dass es an Opera Mail liegt. An "kaputte" Mails oder deren Header glaube ich nicht, denn alles funktioniert ja weiterhin prima mit Opera 12.17.

    Die E-Mail selbst müssen doch gar nicht kaputt sein. Es reicht völlig, wenn es die URL in der E-Mail ist. Außerdem kann es schon einem Unterschied machen, ob die URL an externe Browser weitergegeben wird oder intern weiterverarbeitet wird wie in Opera 12.17.

    Es geht ja auch nicht um nur eine vielleicht komische Mail, sondern um viele, jedoch immer nur mit Sonderzeichen (nicht nur deutsche Umlaute, sondern auch accent aigu, grave, trema, Ćevapčići 😉 usw.). Es hat auch nichts mit der URL zu tun, denn alle Links ohne Sonderzeichen funktionieren.

    Es wäre auch verwunderlich, wenn URLs nicht funktionieren würden, die keine Kodierung benötigen. Das bedeutet aber nicht zwangsläufig, dass die anderen URLs in den E-Mails nicht kaputt sind.

    Wenn es dafür keine Lösung geben sollte, werde ich mich wohl langsam von meinem einst so geliebten Programm verabschieden müssen, bzw. auf Vivaldi hoffen.

    Die sinnvollste Lösung wäre festzustellen, wo das Problem wirklich liegt und es abstellen zu lassen (wenn möglich). Aber das willst du anscheinend nicht. Dann schiebe das Problem aber bitte nicht Opera Mail in die Schuhe.

  • Hallo meersau,

    nehme ich da einen leicht verärgerten Unterton wahr? Du solltest in Betracht ziehen, dass es auch Computerbenutzer gibt, die sich nicht mit den Feinheiten auskennen, von denen in den vorangegangenen Posts die Rede war. Ich kann nur das beurteilen, was ich beschrieben habe, zu mehr reichen meine Kenntnisse nicht. Insofern bleibt mir nicht viel anderes übrig, als die Schuld bei O-Mail zu suchen.

    Wenn du meinst, es gibt einen Weg, "festzustellen, wo das Problem wirklich liegt und es abstellen zu lassen (wenn möglich)", dann möchte ich dich bitten, mir einen solchen aufzuzeigen, und zwar so, dass ich als - na gut, nicht gerade Dummy - aber doch, was Kodierung und "kaputte Mails" betrifft, reichlich unbeleckter Benutzer das auch nachvollziehen kann.
    Dann will ich mir die Mühe gerne machen.

    Gruß
    Wolfgang

  • Ich habe jetzt nochmal Folgendes gemacht. Oben mit rechts in den Header geklickt und "alle Kopfzeilen und die Nachricht anzeigen" angehakt.
    Dann habe ich die gesamte Mail in einen Texteditor kopiert und dort auf den ominösen Link geklickt. Browser wird gestartet und zeigt die Url einwandfrei an.
    Wenn du tatsächlich helfen willst, kannst du dir die Mail als Textdatei hier downloaden:

    http://www.wuphoto.eu/mailtext.txt

    Ich fände es interessant, was dort Falsches oder Kaputtes zu finden ist.

    Gruß
    Wolfgang

  • Die URL in der Mail ist da korrekt kodiert. Es scheint also in der Tat ein Problem in Opera Mail bei der Übergabe an den externen Standardbrowser zu geben.

  • Dann sind wir uns in der Sache also einig. Wohin muss ich mich nun wenden, um "es abstellen zu lassen", um deine Worte zu gebrauchen?

  • Thema hat sich erledigt. Die Lösung war einfach: Den Link nicht mit der linken Maustaste anklicken, sondern mit der rechten und "öffnen" aus dem Kontextmenü wählen. Damit funktioniert es einwandfrei.
    Ein deutlicher Bug in Opera Mail, aber so kann man zumindest damit leben.

    Gruß
    Wolfgang

  • Wohin muss ich mich nun wenden, um "es abstellen zu lassen", um deine Worte zu gebrauchen?

    https://bugs.opera.com/wizard/

  • danke! Hab's eingereicht.

  • Das hättest Du dir sparen können. Opera Mail ist die finale Version. Daran wird nicht mehr gearbeitet.
    Das war und ist ja nur eine Notlösung für die, die M2 nicht missen wollen. Opera Mail war nie als echtes "Projekt" gedacht.

  • naja, egal, so viel Arbeit war es dann auch wieder nicht 😉

Log in to reply