Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Click to run Adobe Flash Player Opera 20.0.1387.64

  • The problem is still on.
    I was on limited Internet for a week and was using Opera Turbo to not seplate my transfer quota too fast and now EVERY flash based thing is fucked up.

    Apart from bandcamp, vines and many other things this is YET ANOTHER big fail since opera was bought by google <- this is the only option for a good web browser to change to shitty chromium.

  • ...since opera was bought by google...

    That never happened, Opera changed to Blink because was better, fast and compatible. Now the devs spend their resources on innovation and improvements, not fixing compatibilities problems.

  • THE FIX: After experiencing this issue I clicked on Opera tab (top left) and saw "Opera Turbo"" was checked so I unchecked it. Now Adobe works again.

  • Hello...

    I had this same issue it DROVE me NUTS! So I am very happy to alleviate someone else's frustrated... OK (the off road mode) doesn't exist. LOOK in opera menu (opera turbo) if that is checked? then just uncheck it and you will be GOOD! t

  • I experienced the same issue with "Click to run Adobe Flash Player". What I was able to do to resolve that issue was to unclick or dismantle the check mark next to OPERA TURBO on the drop down Opera menu. It immediately worked after completing that process.

  • I have found that I had Turbo mode selected. When I unticked Turbo, adobe player started automatically as normal. I never understand what "turbo" is supposed to do, as I don't notice any difference with my snail broadband. Everything seems to be "turbo" these days!

  • With Turbo enabled the data is sent to Opera's servers where it is compressed and then set to you. It does not speed up your browsing and it is not meant to. Its for people on metered connections or with limited bandwidth. Generally most people don't need it and shouldn't use it.

  • If it isnt called "off road mode" then its "Opera turbo." SO annoying.

  • You're annoyed that the changed the name of it?

  • Opera Turbo may be enabled as well. I turned off Turbo and Im good now.

  • there is no option to enable flash player.every document ask for installing flash.butafter downlaod complete.the flash enable process in crome browser is significant....impossible in opera

  • Open up your plugins page and make sure Flash is listed and that its the current version. If its not then you have a problem.

  • Guys, I found a solution ( hope it will work for you too )
    In the uper left corner click on Opera, which will open settings menu, look for Opera Turbo mode, and uncheck it.
    Opera Turbo compresses cache which is going to help you to load pages faster, i am not sure how... but it prevents videos from loading ( prevents flash from running automatically )...

    Anyway worked out for me... i hope it works for u 2 guys.. Good luck 🙂 (Y) !

  • I have experienced YouTube-clicktoplay and now I know this is a feature in turbo mode. Actually I don't worry about data these days. I don't mind streaming a few videos on cellular network, since I have giga bytes per month. I would be at home with limitless wifi anyway, if I can watch YouTube for hours. But I still like turbo mode, which, overall, makes opera performs faster and smoother than safari from what I see. Call it psychological, if u want. My point is, not everyone loves turbo mode because of the savings on data, many going after the blink-fast user experience. Would it be nice to have an option for some level of fine adjustment in turbo or mini mode? Maybe a whitelist for allowing autoplay on some websites?

  • that's very easy.
    i will tell u what u have to do for fix this problem .
    follow my steps, which are given below .......

    1. opera settings
    2. websites
    3. plug-ins........
      select : (Detect and run important plug-in content)
      that's all.
  • for me help, when i switch off opera turbo. then all fine.

  • Since updating Opera yesterday, I've been getting these annoying "Click to run Adobe Flash Player" boxes preventing videos from playing immediately when they load. The video works fine after clicking, but how can I disable this "Click to run" box?
    Edit: Settings > Websites > Plugins is set to run automatically and the problem persists.

    Go to Opera in top left hand corner, click, got to Opera Turbo and make sure it's "unchecked." Worked for me.

  • Many thanks to all who posted on this thread! I was having the "click to open flash player" come up all the time and it was so annoying! Thanks to the comments about Opera Turbo ... I have been able to use flash player without clicking!

Log in to reply