New Opera Forums launching soon!
Discussion thread

Google not recognizing cookies

philh87
philh87

4 posts

    I can't log into any Google-related services. Not Gmail, not Google Drive, not even YouTube, all because since the last update (Opera 45.0.2552.898), Google isn't recognizing my cookies for some reason. I've tried everything I can think of. I cleared my cash and cookies, I restarted my computer, and I even added an exception for Google in my cookies. It's still not being recognized.

    The moment I go to the login page for any Google service, I get a message saying "We've detected a problem with your cookie settings." Nothing I do makes it go away. And I know it's a problem with Opera because I can get Google to recognize my cookies just fine in shudder Microsoft Edge. What can I do?

    16 Replies - 394 Views

    zalex108
    1 0
    zalex108

    1404 posts

    • Server monkey
    • 1000 posts

    Try to access with a Private window.


    Windows 10 (x64) | Anniversary Update
    Opera Stable · Beta · Developer

    Test profile | Back up Linux · Mac · Win

    leocg
    0 0
    leocg

    13255 posts

    • Moderator
    • 10000 posts

    Did you try a clean profile following the instructions?

    zalex108
    0 0
    zalex108

    1404 posts

    • Server monkey
    • 1000 posts

    And about that?

    image
     



    Windows 10 (x64) | Anniversary Update
    Opera Stable · Beta · Developer

    Test profile | Back up Linux · Mac · Win

    philh87
    0 0
    philh87

    4 posts

      Yes, I had already set my cookies like that, and yes, I did try a clean profile. It's working fine in a private window, though.

      leocg
      0 0
      leocg

      13255 posts

      • Moderator
      • 10000 posts

      It's working fine in a private window, though.

      It usually means that an extension is causing it or a bad profile.

      musashim
      0 0
      musashim

      2 posts

        I'm having the same problem as OP and same as him, it only works in a private window. I have tried deactivating my extensions but that does not seem to work. I have Adblocker Ultimate, Disconnect, Ghostery, Adguard Adblocker, Amazon Assistant Opera, BetterTV, HTTPS Everywhere, No-Script Suite Lite, Reddit Enhancement Suite and uBlock Origin.

        leocg
        0 0
        leocg

        13255 posts

        • Moderator
        • 10000 posts

        I'm having the same problem as OP and same as him, it only works in a private window

        Did you check with a clean profile folder?

        musashim
        0 0
        musashim

        2 posts

          Yes I have !

          joshl
          0 0
          joshl

          3747 posts

          • Server monkey
          • 2000 posts

          Forgetting something. Private window means cookies are zero. So clearing cookies AND perhaps getting a clean profile would help.

          Perhaps you might need certain things from your customised profile preserved. For that, there is a procedure: you'll need to do (cleaning) your profile file by file - there've been recommendations here on this forum on how to do it.

          Fool-proof, first you might consider not only renaming your old profile but also moving it into another location to ensure more "cleanness" of the new profile. After the situation amended (if), you'll go checking the two folders against each other file by file. Like reinstating each one you think you need one at a time and see what happens. I mean in the case you need something of your customised stuff there.

          philh87
          0 0
          philh87

          4 posts

            I don't have any extensions, and I didn't have a profile until I made this very post in the forum.

            leocg
            0 0
            leocg

            13255 posts

            • Moderator
            • 10000 posts

            I didn't have a profile until I made this very post in the forum.

            Opera's profile folder is created when you install Opera and is not related to your Opera's account.

            joshl
            0 0
            joshl

            3747 posts

            • Server monkey
            • 2000 posts

            Opera's profile folder is created when you install Opera and is not related to your Opera's account.

            Where the browser keeps all your settings, bookmarks, extensions, etc.

            sherox-oprea
            0 0
            sherox-oprea

            1 posts

              I'm also having issues. It keeps saying enable cookies. I have to use another browser just to access g-mail. VERY frustrating!

              abq
              0 1
              abq

              1 posts

                OK, now here is an interesting scenario, everything Google works for me except gmail; unless i open it in a private mode. I refuse to go nuts over it so I have decided to just open everything concerning my gmail account in private mode. works for me and a hell of a lot less aggravation. but thanks for suggesting it. that's why i now do it

                operafox
                0 0
                Cat

                11 posts

                  I had this in Firefox for years. Google and Verizon refused to recognize my cookie settings. I think it was a bug in Firefox, maybe the way the cookies were configured.. I had to use Opera for those 2 sites for a couple of years. Ironic.

                  joshl
                  0 0
                  joshl

                  3747 posts

                  • Server monkey
                  • 2000 posts

                  As I reckon, sites may establish the language settings checking
                  --- apart from the site's own interface and such prefs --
                  ** browser language settings (or language version),
                  ** system language settings/version,
                  ** actual (or ''initial'' -- usually appears as erroneous) location.