New Opera forums launching soon!
Discussion thread

Opera Browser Installation Issue on Debian Stretch


1 posts

    Hello Opera community,

    I happen to have upgraded my debian machine to a fresh installation of stretch, keeping my data in a /home partition. Now I'm reinstalling my favorite softwares including Opera which is the goto browser on all my machines.

    I've tried to download the .deb package from Opera's website (opera-stable47.0.2631.55amd64.deb) but when trying to install the package I get a pop up saying "Sorry, this did not work. This file is not supported".

    Then I fell back to an apt installation, first following the instructions there: adding the source for apt. However when trying to install with apt-get there seem to be some impossible dependencies that stop the browser from being installed. You'll find below the information I got from the terminal.

    Is this a known issue with Opera and stretch ? Any workaround available or even better a stretch compliant version in sight ?

    Thanks in advance for your help.

    root@debian:~/.gnupg# apt-get update Ign:1 stretch InRelease Get:2 stable InRelease [2,592 B]
    Hit:3 stretch-updates InRelease
    Hit:4 stretch/updates InRelease
    Hit:5 stretch Release
    Ign:6 stretch InRelease
    Hit:8 stretch Release Fetched 2,592 B in 0s (3,120 B/s) Reading package lists... Done root@debian:~/.gnupg# apt-get install opera Reading package lists... Done Building dependency tree
    Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

    The following packages have unmet dependencies: opera : Depends: libgstreamer-plugins-base0.10-0 (>= 0.10.16) but it is not installable Depends: libgstreamer0.10-0 (>= 0.10.15) but it is not installable Depends: gstreamer0.10-plugins-good but it is not installable Recommends: flashplugin-nonfree but it is not installable Recommends: cups-client but it is not going to be installed E: Unable to correct problems, you have held broken packages.

    2 Replies - 115 Views

    0 0

    25 posts

      That dependency for libgstreamer0 is for real old versions of opera. If you have an old version of opera installed, try uninstalling it and removeing any reference to opera sources in /etc/apt/sources.list. If you successfully install a new version, it should add a new source to your /etc/apt/sources.list.

      v47 installed ok on my machine. I installed with dpkg -i --simulate to check for problems first.

      0 0

      127 posts

        2 things to take into account

        a) Opera's package name now is "opera-stable", so you have to use "apt-get install opera-stable" to install it. Using "apt-get install opera" will try to install the old presto opera 12.16, which is obsolete for a long time now.

        b) The "this file is not supported" means you tried to install the amd64 package on a 32bit system. If you really are on 32bits, the above will install opera 45.x. which is the last 32bit version of opera.