Forums are closed as read-only due to our ongoing migration to the new forums page.
Discussion thread

Opera always sets itself as my default Mail App

gustaf333
gustaf333

1 posts

    Hi,

    so I am experiencing the following issue: Opera always sets itself as my default Email App. When I click on an email address, not Mail App but another mail account I'm using opens in Opera. I always have to change the setting in the Mac Mail app. Anyone ever experience something like this? The setting changes back again after a while. I assume its when I close Opera. Thanks!

    12 Replies - 982 Views

    richard-dovshan
    0 0
    richard-dovshan

    1 posts

      I confirm same problem!

      patman67
      0 0
      patman67

      2 posts

        I have the same problem. OSX 10.10.5. When I change the default mail reader from within Mail, it will remain so until the next time I open the Opera browser, regardless if I click on an email link or not. Just opening the Opera browser modifies the Mail preference setting so that Opera is now the default email reader.

        This is an issue because the option to use Mail disappears from the Share menu, until I go back and change the default reader back to Mail again!

        ivanzarco
        0 0
        ivanzarco

        3 posts

          I havent had this problem. Are you using a email associated with Opera? I use Gmail and I dont have this issue.

          chbrunne
          0 0
          chbrunne

          1 posts

            Same problem here...

            patman67
            0 0
            patman67

            2 posts

              I use Opera as a browser and I use Mail as the email client. In the preferences in the Mail program, there is a setting for Default Email Reader. When that is set to Mail, as I want it, the Share menu within other programs allows me to email from within the program, like from within Pages.

              However, when the preference is set in Mail for Mail to be the Default Email Reader, after opening the Opera Browser, the preference in Mail is automatically (annoyingly) to be Opera as the Default Email Reader. The Share menu loses it's Email option, and I have to reset the preference in Mail.

              My email address is gmail, and my wife has AOL. Our addresses are not associated with Opera; it's a problem with the software.

              atmasvarupa
              0 0
              Earth

              1 posts

                Same problem here. Are they looking into fixing it. I deleted opera from my system just because of that problem.

                adnavis
                0 0
                adnavis

                2 posts

                  Exactly the same problem here

                  The following was posted in the Apple Support Communities forum (but I fear that the answer should come form Opera Community)


                  Although I keep setting the Default Email Reader in Mail Preference to 'Mail', the system keep resetting it to 'Opera' Each time Mail is closed and reopened, the default email reader previously set to 'Mail' will show 'Opera' …

                  Extremely annoying, since when clicking on a email link, it will keep opening a new message in Opera, instead of Mail (my default email application).

                  Restarting, Disk Utiliy > First Aid did not help. Any suggestion to correct this annoyance is welcome.

                  OS El Capitan 10.11.6 Mail 9.3 Opera 40.0 latest update


                  Any help is very welcome.

                  swedson
                  0 0
                  swedson

                  1 posts

                    Same problem here as well. I think Opera must clear this problem with next update. It's really annoying that Opera forces this way. In fact worse than Google or Apple. May be it's better to stick with Safari.

                    grandezero
                    0 0
                    grandezero

                    1 posts

                      I had the same issue but after using macOS Sierra it disappeared and the Mail.app has stayed after that. I have not changed anything else in the mail settings.

                      akalakatx
                      2 0
                      akalakatx

                      1 posts

                        The problem is caused because Opera is using a handler to manage a web-mail application automatically. You can stop this behavior from happening by going to Opera -> Preferences -> Privacy & Security, then in the Handlers section delete any association with a webmail application in Opera.

                        Save preferences and you will see that the problem is gone.

                        Have a great day!

                        adnavis
                        1 0
                        adnavis

                        2 posts

                          Thank you akalkatx, this new feature has indeed fixed the problem.

                          However note for other users, you still have to go in Mail>Preference>General to reconfirm the default email reader as 'Mail'.

                          Changes only take effect after a restart.

                          stefan344
                          0 0
                          stefan344

                          1 posts

                            Found a solution at https://forums.developer.apple.com/thread/14502 Per user Max108: Normally, your change to default email client is saved by LaunchServices, but that database can become corrupted. You can reset the database with the following command in Terminal (copy-paste the whole thing):

                            /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -r -all local,system,user

                            OS X will have to re-learn your preferred non-default apps for opening different types of files again, but it may fix the issue.

                            That did it for me.