Opera 32 on Ubuntu bookmarks page rendering broken

jamesisin
jamesisin

26 posts

  • Server monkey

This odd rendering, an apparent echoing of the top-left portion of the browser, only effects the Show All Bookmarks page. Possibly relatedly, the bookmarks popup menu appears empty (though can be clicked if you make good guesses about the locations of things inside it). This was not the case with Opera 31, and this is effecting all users on this system.

You can get more detailed information and see an image of the page rendering at my blog:

A High-Tech Blech!

24 Replies - 2277 Views

jamesisin
1 0
jamesisin

26 posts

  • Server monkey
gustavwiz
3 0
gustavwiz

680 posts

  • 500 posts

Start opera from the terminal with this command:

opera-beta --disable-gpu-compositing
peterb0309
0 0
peterb0309

2 posts

    How can I get rid of this problem but still using Gpu-compositing?

    peterb0309
    0 0
    peterb0309

    2 posts

      I realize that when I enable-gpu-accelerate >> open Opera >> bookmark rendering broken BUT (continuing) open New Private Window >> everything is OK!

      Hope this helps and somebody finds the way to fix it soon.

      jamesisin
      0 0
      jamesisin

      26 posts

      • Server monkey

      I'm not running beta so my command was "opera --disable-gpu-compositing", but that did fix the rendering issue in Opera 32.

      Is there a setting I can use (perhaps under flags/) to make this permanent? I mean, at least until they fix this bug of course.

      jamesisin
      0 0
      jamesisin

      26 posts

      • Server monkey

      Also, I was able to confirm peterb0309's behavior. If you run Opera 32 normally bookmarks do not render correctly, but if you open a New Private Window and navigate that window to Show All Bookmarks it does render correctly.

      i-am-mike
      0 0
      i-am-mike

      2 posts

        Same behavior on latest opera-develper 33 on arch-linux.

        jamesisin
        0 0
        jamesisin

        26 posts

        • Server monkey

        I poked through opera:flags and didn't find anything which appeared to effect this matter.

        i-am-mike
        1 0
        i-am-mike

        2 posts

          I had problems with Chrome GPU rendering, which started lagging after a few minutes of browsing, until it became unusable, when used with the Hardware Acceleration option - ON. As Opera is based on Chromium as well, it suffers from some GPU rendering problems, which caused the defective rendering in the Bookmarks menu, and when opening some extensions' menu (like adblock).

          The solution is to launch Opera (or Chrome), with the following command, which disables the problematic DRI3, and reverts to the old one:

          LIBGL_DRI3_DISABLE=1 opera --ignore-gpu-blacklist

          Hope I saved someone a few days of Trichotillomania :)

          gustavwiz
          1 0
          gustavwiz

          680 posts

          • 500 posts

          @peterb0309:

          How can I get rid of this problem but still using Gpu-compositing?

          You should install the proprietary driver from your graphics card manufacturer and use that one instead of the default open-source (x.org).

          If you're using Ubuntu, you can probably easily change the driver by opening "Software and Updates" -> "Additional Drivers".

          jamesisin
          1 0
          jamesisin

          26 posts

          • Server monkey

          I have confirmed that switching my video driver from xorg to the latest Nvidia proprietary driver (using Software and Updates --> Additional Drivers) does fix the rendering issue.

          jamesisin
          0 0
          jamesisin

          26 posts

          • Server monkey

          Unfortunately, my Lenovo w500 at home has no additional drivers available...

          gustavwiz
          0 0
          gustavwiz

          680 posts

          • 500 posts

          Does it have amd/ati, nvidia or intel (integrated) graphics?

          jamesisin
          0 0
          jamesisin

          26 posts

          • Server monkey

          I guess it's ATI Mobility, but I can't check from here. Is there a command I can use to get that easily?

          Behavior is essentially the same though: private windows do not exhibit the problem. I did notice that any window on start can render in this broken manner. A restart of the application has fixed this both times it has happened.

          sgunhouse
          0 0
          sgunhouse

          3761 posts

          • Moderator
          • Server monkey
          • 2000 posts

          Does disabling "Use hardware acceleration when available" in Settings help? You'll need to enable Advanced settings (bottom of the Browser page) to see it, then it'll be right above that.

          zluka13
          0 0
          zluka13

          2 posts

            You should install the proprietary driver from your graphics card manufacturer and use that one instead of the default open-source (x.org).

            AMD no more support graphic cards below hd5000 for linux.

            Does disabling "Use hardware acceleration when available" in Settings help? You'll need to enable Advanced settings (bottom of the Browser page) to see it, then it'll be right above that.

            It helps but make YouTube sucks when HD resolution used.

            jamesisin
            0 0
            jamesisin

            26 posts

            • Server monkey

            sgunhouse - Yes, disabling hardware acceleration does allow non-private windows to function as expected. (Private windows remain unaffected by this problem.)

            An update came out today and I was hoping it may address this, but no luck...

            avl
            0 0
            avl

            423 posts

            • Opera employee
            • Moderator

            This is very unfortunate, and due to a bug in the X.org drivers: https://bugs.freedesktop.org/show_bug.cgi?id=90264 . This bug report also contains a patch that fixes the issue.

            kgiii
            0 0
            kgiii

            65 posts

              @avi - I'm curious... If, and only if, you have time could you elaborate on how to use those patches? I saw one at 40 and one at 45 and somebody further commented that they worked. I'd be interested in testing this but, frankly, I have no idea. So, if you don't have time then don't let me interrupt you - I might be able to figure it out on my own or Google might have an answer. :doh:

              jamesisin
              0 0
              jamesisin

              26 posts

              • Server monkey

              This appears to have been fixed in a subsequent update. I again have hardware acceleration enabled and I am able to interact with both the bookmarks page and the bookmarking menu in non-private windows. (I am now running 33.0.1990.43 in Ubuntu and elsewhere.)

              sinjab
              3 0
              sinjab

              1 posts

                I also encountered this problem on my Ubuntu. I used what "i-am-mike" said like this:

                edit this file:

                sudo vi /usr/share/applications/opera.desktop

                replace the first "Exec" line with this: Exec=env LIBGLDRI3DISABLE=1 opera --ignore-gpu-blacklist %U

                reopen opera and the problem is solved

                johnhooley7
                0 0
                johnhooley7

                1 posts

                  Thanks sinjab! Works like a charm.

                  mklinuxuser
                  0 0
                  mklinuxuser

                  13 posts

                    I also get this problem, on Opera 35. If this is not an Opera bug (but in the driver) then why is other software not having the problem?

                    xfranky
                    1 0
                    xfranky

                    2 posts

                      @sinjab forgot to escape the underscore ;)

                      Exec=env LIBGL_DRI3_DISABLE=1 opera --ignore-gpu-blacklist %U