New Opera Forums launching soon!
Discussion thread

Opera crashes and will not start after upgrade (48)

mklinuxuser
mklinuxuser

18 posts

    Opera crashes and will not start since upgrade. Version is given as 48.0.2685.32 Ubuntu (15.10) crash reporter states SIGABRT It doesn't allow me to copy and paste the crash details, and it appears that I can't include a screenshot here. Also in the crash reporter is "Unreportable reason - This is not an official Ubuntu package".

    Now looking for a way to convert bookmarks to use in Firefox, but Opera won't start to allow me to export them.

    9 Replies - 301 Views

    ivanmichaelovitch
    0 0
    ivanmichaelovitch

    5 posts

      Similar problem. Upgraded an hour ago. Opera (mini) now doesn't work. uninstalled, reinstalled, New one doesn't start, says Can't connect. All other applications fine.

      jimunderscorep
      0 0
      jimunderscorep

      127 posts

        Ubuntu 15.10 is unsupported since July 2016, so probably opera wants a newer version of some library it can not find, so it crashes. So upgrade to 16.04 at least.

        sgunhouse
        0 0
        sgunhouse

        3871 posts

        • Moderator
        • Server monkey
        • 2000 posts

        If you want to see what Opera says, open a terminal and start it from the terminal. Normally you'll see a number of messages anyway, so the output could be pretty long.

        You can do screenshots, but you need to upload them to some external site then embed them in your post. At least, until the forum update.

        mklinuxuser
        0 0
        mklinuxuser

        18 posts

          Ubuntu 15.10 is unsupported since July 2016

          Okay, but it showed the update & allowed me to install it.

          mklinuxuser
          0 0
          mklinuxuser

          18 posts

            I have installed a previous package version found in /var/cache/apt/archives. For anyone else having this problem this is what I did (after cd to the above directory):

            sudo dpkg -i opera-stable_47.0.2631.80_amd64.deb
            

            This will do for now. I have been intending to upgrade to a newer Linux OS but still need to make sure I have backed up some data which I have not finished doing yet.

            mklinuxuser
            0 0
            mklinuxuser

            18 posts

              It looks like it is libnss3. From the terminal:

              [1003/135841.876808:FATAL:nssutil.cc(632)] NSSVersionCheck("3.26") failed. NSS >= 3.26 is required. Please upgrade to the latest NSS, and if you still get this error, contact your distribution maintainer.

              0 0x000001cbb477

              1 0x000001cd05f1

              2 0x0000021b7f16

              3 0x0000020feab5

              4 0x0000020a0bb8

              5 0x000001ffd363

              6 0x00000068bd6a

              7 0x00000068bcd2

              8 0x000000775e68

              9 0x000000c2019d

              10 0x000001d16f30

              11 0x000001d11c43

              12 0x7f9d5ff9e6aa start_thread

              13 0x7f9d5f7c713d clone

              Discarded=1 Aborted (core dumped)

              jimunderscorep
              1 0
              jimunderscorep

              127 posts

                It would be more useful to tell us which version of libnss3 is installed in ubuntu 15.10, like so

                apt-cache show libnss3 | grep Version

                because packages.ubuntu.com does not list your version's packages anymore.

                mklinuxuser
                0 0
                mklinuxuser

                18 posts

                  The output of that command strangely shows two lines:

                  Version: 2:3.23-0ubuntu0.15.10.1
                  Version: 2:3.19.2-1ubuntu1
                  

                  In Synaptic it shows the installed version is 2:3.23-0ubuntu0.15.10.1

                  jimunderscorep
                  0 0
                  jimunderscorep

                  127 posts

                    You can find which version comes from where with "apt-cache policy libnss3". However, both are too old now, because all the working repos of ubuntu (14.04, 16.04 and to 17.10) have 3.28 (2:3.28-whatever), so yes, an update is mandatory for you now.