New Opera Forums launching soon!
Discussion thread

I have "Download Chrome Extension" add-on, but i still can't download Chrome extensions

raspythroat
raspythroat

34 posts

    I have "Download Chrome Extension" add-on, but i still can't download Chrome extensions


    Opera

    Version: 47.0.2631.80 - Opera is up to date

    Update stream: Stable

    System: Linux Mint 18.2 (x86_64; X-Cinnamon)


    I have Download Chrome Extension by Opera Software

    https://addons.opera.com/en-gb/extensions/details/download-chrome-extension-9/

    Version 2.3.0 is what I have.


    But I still can't download/install Chrome extensions.

    I go to Chrome Store (https://chrome.google.com/webstore/)

    I find the extension I want.

    I click the red "Add to Opera" button.

    A pop-up message appears. It says "Unable to download extension package due the network error.

    Check your internet connection and try again"

    But I have no problems with internet connection. I've tried several Chrome extensions, and they all give the same error message. Please feel free to try it yourself.

    16 Replies - 338 Views

    jimunderscorep
    1 0
    jimunderscorep

    127 posts

      I just installed both opera-developer and opera-beta and the problem is there as you describe. I will file a bug report on the projects' github page. However, I won't risk removing and reinstalling it on opera-stable just to check, because it is my main browser for now.

      escalepion
      1 0
      escalepion

      8 posts

        i have same problem exactly. i have tried 3 versions of opera: opera stable, opera beta, opera developers

        i really want to use opera rest of my life but it doesnt possible without chrome ectensions. can someone help me please?

        opera version: 47.0.2631.80 beta version : 48.0.2685.22 developer version: 49.0.2711.0

        os is: linux mint 18.2 cinnamon . thanks

        rudrick
        1 0
        rudrick

        150 posts

          You might want to use this ext instead: In addition to it being an installer, you can also view the code with it without installing first (good to browse for http and https for possible tracking), and with CRX one can also download extensions as ZIP. Works also on Mozilla/FF addons and possible elsewhere.

          https://addons.opera.com/en/extensions/details/extension-source-viewer/?display=en

          jimunderscorep
          1 0
          jimunderscorep

          127 posts

            I have been using the new opera since version 43 was on developer channel and that is when I installed the extension for getting chrome ones.

            The problem is where will you get an old version of opera? The repo only provides opera 47 for 64bits and 45 for 32 bits, which is also what the download page will get you, whether you like it or not :P

            jimunderscorep
            0 0
            jimunderscorep

            127 posts

              No problem here. It dropped me to the extensions page after clicking "add to opera", asking be to enable the extension I just installed. Nothing more, nothing less.

              Opera 47.x on debian testing x64.

              raspythroat
              0 0
              raspythroat

              34 posts

                Still not working for me. What is wrong with my Opera?

                jimunderscorep
                0 0
                jimunderscorep

                127 posts

                  I do not know, but feel free to install opera-beta or opera-developer and try it there. A more harsh solution would be to backup your favorites, uninstall opera, remove ~/.config/opera-stable, reinstall opera and start fresh.

                  escalepion
                  0 0
                  escalepion

                  8 posts

                    doesnt anybody know about this problem ? i saw same problem in the extension's page but not any solition. i thought that contact with the author bur i saw that the author is opear corp. :) please someone give a clue

                    escalepion
                    0 0
                    escalepion

                    8 posts

                      so what is your extension version? i just want to understand that if the problem is about opera or about extension?

                      if the problem is about extension, can i download the older version of this extension? or if the problem is about opera, how can i add opera's previous version? http://help.opera.com/Windows/12.10/en/oldversions.html this link didnt help me.

                      jimunderscorep
                      0 0
                      jimunderscorep

                      127 posts

                        Do not download the old, presto-based, opera. It is obsolete now and it does not work properly on many sites, especially ones that are on https.

                        The installed extension is on version 2.3.0, which is the same on addons.opera.com.

                        escalepion
                        0 0
                        escalepion

                        8 posts

                          so what should i do? is the only thing that waiting for the bug is fixed????

                          escalepion
                          0 0
                          escalepion

                          8 posts

                            and i didnt meant that very old version. i can install 46 or something else if it can help

                            escalepion
                            0 0
                            escalepion

                            8 posts

                              so there isnt no choise else waiting :(

                              escalepion
                              0 0
                              escalepion

                              8 posts

                                by the way i was able to download some extensions and some were not. i downloaded fresh start, great suspender, react developer tools, google translate etc... but i couldent download some. for example tabs outliner..it is really weird :S

                                escalepion
                                0 0
                                escalepion

                                8 posts

                                  you are my hero my friend...aplauseeeeeeeeeeeee :))) more people should know about this extension.

                                  l33t4opera
                                  0 0
                                  l33t4opera

                                  860 posts

                                  • Server monkey
                                  • 500 posts

                                  The problem is where will you get an old version of opera?

                                  Hi @escalepion, @jimunderscorep, the versions of old Opera on Presto engine, and versions of new Opera are available on the official ftp servers, for example: versions 11.00 to 12.16 of old Opera for Linux are placed here, the versions of new Opera stable are here. You can also find the rest of old Opera's versions archived here.