New Opera Forums launching soon!
Discussion thread

Setting Opera as default browse

hatrack
hatrack

12 posts

    Greetings to all readers -

    I know how to set Opera as the default browser (Settings>Browser>Default Browser) but this setting is lost when Opera closes. Is there any way to make Opera retain the chosen setting between sessions ? Thank you for reading my question Best regards to all --

    6 Replies - 121 Views

    hatrack
    1 0
    hatrack

    12 posts

      To sgunhouse -- Thank you for your question. I thought in my ignorance that this was a generic problem and so didn't provide this basic information --- obviously I was wrong and I apologise for confusing things.

      System - Dell Optiplex 980 series mini-tower with 8 GB of RAM and over 100 GB free disk space. Op Sys: LinuxMint version 17.3, 64-bit, Mate desktop. Kernel Version: 4.4.0-45, fully up-to-date. Opera version; 47.0.2631.80 (Stable) - reported as up-to-date in "About Opera". Opera and a Password safe are the only programs running

      I hope this information is sufficient and I look forward to your reply in due course - Best regards - hatrack

      sgunhouse
      0 0
      sgunhouse

      3869 posts

      • Moderator
      • Server monkey
      • 2000 posts

      What is your desktop and distro? There are settings for default browser in both your desktop and your terminal's shell, and of course it is unlikely for any program to do settings properly in every possible desktop ...

      jimunderscorep
      0 0
      jimunderscorep

      127 posts

        In any debian based distro (mint is ubuntu based, ubuntu is debian based, so mint is debian based too) you can set the default browser with

        sudo update-alternatives --config x-www-browser

        and selecting your browser in the list. This is system-wide configuration, so it will probably work under mate or any other desktop enviroment you may install in the future. If it does not work under mate it means that mate ignores the x-www-browser setting, so blame mate.

        And that is the reason this exists

        sudo update-alternatives --config gnome-browser

        because gnome does ignore the above setting. You can try that as well, because mint uses some of gnome's apps and libs to work.

        hatrack
        0 0
        hatrack

        12 posts

          Hi Jim

          I thank you for your reply but I am afraid neither of the two alternatives has worked --- the previously-set condition of "Default browser" is still being lost when Opera closes..

          It seems from what you said that the cause of this problems is fairly obscure but, somehow, is indeed caused by Mint. I will put a post on the Mint forum and see what transpires. I will keep monitoring the Opera forum in case anyone thinks of a suitable/relevant comment and I will report back here with whatever I find out from the Mint forum.

          Regards -- hatracvk

          hatrack
          0 0
          hatrack

          12 posts

            Hi all -- Further to my previous post, I decided to do some more testing before writing to the Mint forum and I have made a surprising discovery ---

            I am evaluating browsers because Firefox (which has been my choice for many years) is to change soon and none of the add-ons will then work. So, in addition to Opera, I have Firefox and Vivaldi installed. Both of these can be set as default and will hold this condition over shut-down and restart.

            It would appear, therefore that the problem is due to Opera itself or in the way it interacts with Linux Mint.

            Versions of these other browsers are currant and are --

            Firefox -- 55.0.2 (64-bit) - "Mozilla Firefox for Linux Mint 1.0" Vivaldi -- 1.11.917.43 (Stable channel) (64-bit)

            Regards to all --

            hatrack
            0 0
            hatrack

            12 posts

              Greetings to all !

              Further to my last post I submitted this question to the linux Mint forum. I got a couple of answers back but neither directly solved the problem. However, they lead to further experiments and I have now found the cause.

              I run my browser and email client (Thunderbird) in a sandbox, using the "firejail" utility. If the condition of default browser is set whilst the application is running sandboxed then, the setting will be lost on exit because firejail stops anything being written outside the sandbox, except to the directory "Downloads".

              If Opera is run outside the sandbox then the condition "default browser" can be set and will persist after exit. However, Opera running in a sandbox is (functionally) a different entity so, one cannot set the default condition and hope it will be preserved inside the sandbox. The solution to this probably requires a different custom profile for Opera and I will probably develop this at some future date.

              I hope this report will be useful in some way to others.

              Best regards to all ---