New Opera Forums launching soon!
Discussion thread

Default search engine displays all the results in Spanish

michaelbr
Earth

23 posts

    Can someone please tell me what I'm doing wrong? I followed the FAQ to change the default country, but for some reason it's not working and I have no idea what I missed, here are the steps that I did:

    1) opened Opera, went to Settings > Privacy & Security > Privacy > Clear browsing data and checked Browsing history, Download history, Cookies and other site data, Cached images and files and selected from beginning of time, and pressed Clear browsing data button.

    2) closed Opera

    3) changed Local State file as instructed, and the new data is "location":{"country":"us","countryfromserver":"US", but when I open Opera again, the search still shows in Spanish and on the right hand side, there's a pop up message asking if you want to change to English.

    Did I miss some steps?

    13 Replies - 211 Views

    operadesktopqa
    0 0
    operadesktopqa

    7 posts

      Sometimes editing lines in this file isn't good idea because of bad file coding after saving. Simple editors doesn't respect original file coding.

      Try to change "Local State" file to "Local State Old".

      michaelbr
      0 0
      Earth

      23 posts

        Sorry, I'm lost, what happens if I just change the name of the file, I suspect that Google uses your location to direct their advertising, so if I'm living in Spain, every single time, Google will use your current location to direct their ads, if you don't "hard code" your preferred location in a file. Am I missing something?

        gabrieljonathan123
        0 0
        gabrieljonathan123

        48 posts

          Something similar. They are tracking your Locale and information related to nearby vendors or accessible vendors. If you want the content to be displayed in English all the time, either use explicitly google.com and nothing else, or try changing your Windows Locale from Spain to UK or US.

          leocg
          0 0
          leocg

          13255 posts

          • Moderator
          • 10000 posts

          What is your default search engine? If Google, it's using google.com or it's redirecting to some local Google page?

          What editor are you using to edit 'Local State'? I recommend using Notepad++.

          Also, did you change the site preferences to show results in English for you?

          michaelbr
          0 0
          Earth

          23 posts

            That's right, I'm using Google, and already tried to use google.com, it changed EVERY SINGLE time to google.es.

            Yes, I'm using Notepad++ for editing, after changed the file, went back to confirm, and it showed location":{"country":"us","countryfromserver":"US", which I assume the change is accepted, but still when I try to do a search, Spanish google came up and not in US, what else can I do?

            Yes, the preference has been changed too.

            michaelbr
            0 0
            Earth

            23 posts

              Here goes one more unhappy Google user, I'm replacing Google with DuckDuckGo, tired of doing things their way, regardless of user feedback, already dropped gmail, now it's Google search, Google will be the next MS!!!!

              leocg
              0 0
              leocg

              13255 posts

              • Moderator
              • 10000 posts

              what else can I do?

              Try cleaning cache and cookies. Also disable geolocation for Google.

              michaelbr
              0 0
              Earth

              23 posts

                Can you please tell me how to disable Google's geolocation? I've tried cache and cookies to no avail. As far as I know, Google won't let you change it, I've tried also change settings, and also useless, everytime you shut down the pc, it goes back to Spanish, it's like a nightmare that never goes away.

                leocg
                0 0
                leocg

                13255 posts

                • Moderator
                • 10000 posts

                Can you please tell me how to disable Google's geolocation?

                Did you ever allowed it? Check in settings > Sites > Local > Manage exceptions.

                michaelbr
                0 0
                Earth

                23 posts

                  I don't remember allowing it, but you never know, those crappy sites are sneaky, they install/enable it by using small prints or during updates.

                  Sorry, I don't have sites under setting, when I click on settings (right side bottom) in google search, I have the following options: Search settings Advanced search History Search help Send feedback but no Sites, if I can attach a screenshot, I can show you what I meant, are you using Windows 10? It shouldn't matter which OS, it's in the browser.

                  leocg
                  0 0
                  leocg

                  13255 posts

                  • Moderator
                  • 10000 posts

                  Sorry, I don't have sites under setting, when I click on settings (right side bottom) in google search

                  We are talking about Opera's settings.

                  michaelbr
                  0 0
                  Earth

                  23 posts

                    Sorry, under Settings > Websites > Location > Ask me when a site tries to track my physical location (recommended) was selected, now I changed it to Do not allow any site to track my physical location.

                    Also, under Manage Exceptions there's one entry: https://www.google.es:443, and under Behavior shows block, so I assume it'll block Google ES to track me, right?

                    leocg
                    0 0
                    leocg

                    13255 posts

                    • Moderator
                    • 10000 posts

                    so I assume it'll block Google ES to track me, right?

                    Yep but it may also mean that the redirection is not related to geolocation.

                    Can you try adding google.com and see what happens?