New Opera Forums launching soon!
Discussion thread

Stop Opera asking "Allow inbox.google.com" to open all email links

benjilb
benjilb

1 posts

    I don't need Inbox to do this, I have a mail handler. But every time I check Inbox I get this pop up in the notification area.

    How do I disable this? I can click the X or click Allow - I want to say Never.

    - 126 Views

    burnout426
    1 0
    burnout426

    1018 posts

    • Server monkey
    • 1000 posts

    On Windows, a notification bar pops down under the address bar. It has "Allow", "Deny" and an 'X'. Then, you can manage them via "Menu -> Settings -> Privacy and Security -> Manage Handlers" where you can them delete items from the active and ignored lists. If a domain is in the ignored list (by clicking "Deny"), you won't get prompted again.

    Sounds like there's no "Deny" on Mac. I don't know if that's a bug or something to do with UI/UX on Mac. But, what happens if you go to "Manage Handlers"? Does it have an option to manually add inbox.google.com to the ignored list?

    If not, you could probably add it manually by closing down Opera and editing the "preferences" file in your Opera profile.

    In the file you should see and need to edit (or add it if it's not there) an "ignored_protocol_handlers" object whose value is an array of objects, each representing an ignored handler. For example:

    ...,"ignored_protocol_handlers":[{"protocol":"mailto","url":"https://inbox.google.com/?mailto=%s"}],...