New Opera Forums launching soon!
Discussion thread

Flash video problems never end

tastymineraler
tastymineraler

1 posts

    One of the reasons why Opera is a bad browser for Linux and why nobody from common users will ever stay with it long enough to make it their default is the fact that Opera does not come with out-of-the-box support for various video streaming formats. I have just installed 43 version to see what's new cool stuff has been added only to find out that I still can't play flash videos from the web sites and some videos on youtube: "Your browser does not currently recognize any of the video formats available". So, imagine a typical user that sees this message on his favorite youtube or whatever. His next reaction will be "ok, I'll try something else, uninstall", he does not care about why and what, he wants things done. Well, if this user really likes Opera features, he'll go to "support & help" section on opera.com and try to figure out what's wrong there. He'll find out that "You just need to install the latest Adobe Flash Player." But I have already installed it "flashplugin 25.0.0.127-1 [installed]" so what am I missing? He will probably try and google posts dating from 2009, 2012, 2014 which involve some console magic skills, library mangling and other voodoo stuff. Will he even understand what is going on? Eventually he will give up and drop it. So, my point is. It is 2017 and I see that nothing changed, same problems as in 2014, 2015, 2016, I still can't watch most videos from the Internet on Opera. I don't care what other "killer" features it might have, because in truth, it simply doesn't, all browsers more or less packed or can be extended with plugins. With this post I am not seeking answers, I don't want to open a console and start debugging why something does not work when it should. I am just giving your feedback.

    Oh and btw, I have installed vivaldi which is not even in the official repos and it works, videos are all getting played correctly. I didn't have to browse through numerous web sites in search for solution. Why is that, I wonder?

    24 Replies - 1112 Views

    huwanhsin
    1 0
    huwanhsin

    36 posts

      100% agree with you. I follow what's said in http://ubuntuhandbook.org/?s=ppapi & the problem is solved on Opera 44.0 of 32-bit ubuntu 14.04 LTS.

      krege
      0 0
      krege

      1 posts

        And if not Ubuntu? rmp-based actually.

        huwanhsin
        0 0
        huwanhsin

        36 posts

          Is rpm-based what yu mean? No experience at all. Sorry!

          csevcik
          0 0
          csevcik

          2 posts

            Well, I like Opera. Is fast and gas a great bookmark tab system, much better than Google Chrome and is much faster that Firefox. But damn it, Why in heck can't I see CNN videos? Why do I get a black Screen with the "UNDEFINED info: The browser does not allow you to watch this video. ....."? I am using Ubuntu Linux 16.10 and have installed the flashpepper plugin with either the Synaptic Manager option and de Adobe Pepper Player instruction. The phoniest thing is that it works in some machines and nor in others with exactly the same OS. YouTube works great and sites such as ABCnews work too. CNN videos work under Firefox or Google Chrome in the same machine.

            CAN ANYBODY HELP???

            huwanhsin
            0 0
            huwanhsin

            36 posts

              brumman
              0 0
              brumman

              4 posts

                Yes opera has become a real pain with this ongoing video problem. I had to role back to the last working stable system (42 .xxx) but finally decided that by now the latest version 44 would probably be fixed! Some hopes eh? I do like opera but this is ridiculous, I would use Vivaldi but it has dependency issues with my Ubuntu version so got to wait until I install Ubuntu 16. Is this all the result of the Chinese take over?

                huwanhsin
                0 0
                huwanhsin

                36 posts

                  Hi! Bruman. Frankly speaking, this flash problem occurred long before the Chinese take Opera over. Maybe Opera doesn't value the users of Opera Linux.

                  jayaguru-shishya
                  0 0
                  jayaguru-shishya

                  65 posts

                    @tastymineraler I couldn't agree more. I made a rather extensive summary of the problem here. I must say that I've been really patient with opera, and still given it the third, fourth, and fifth chances instead of just switching to Chromium directly.

                    Well, if you take a look at the summary I linked to you, there you will find in one place all the different voodoo tricks that you can try in order to fix the problem. I also organized the proposals in four distinctive sections. For me, the option number one did the trick. The recipe in short goes as follows (the instructions how to run the code is given in the other thread as well):

                    1. Install pepperflash-nonfreeplugin
                       (and purge all the others)
                    
                    2. Install the necessary Chrome libs for H.264/MP4
                       codec
                    3. Boot your system
                    4. Volah!
                    

                    I hope this helps to fix your problem. Cheers!

                    cybrsaylr
                    0 0
                    cybrsaylr

                    68 posts

                    • Server monkey

                    jayaguru-shishya thanks for the above info. However wondering if you or someone has the code for doing that so it can be done in a Terminal?

                    jayaguru-shishya
                    0 1
                    jayaguru-shishya

                    65 posts

                      someone has the code for doing that so it can be

                      @cybrsaylr Hi! The code is behind the thread I linked. Well, what the heck, I'll just put it here for you:

                      sudo apt-get install chromium-codecs-ffmpeg-extra
                      sudo mkdir /usr/lib/x86_64-linux-gnu/opera/lib_extra/
                      sudo ln -s /usr/lib/chromium-browser/libs/libffmpeg.so /usr/lib/x86_64-linux-gnu/ope
                      

                      I hope it works for you! Cheers!

                      scottalan
                      0 0
                      scottalan

                      1 posts

                        I just did the latest security update and as usual, my video doesn't work. (again.) This is why I give Opera 2 stars as a browser for Linux.

                        I guess it's time to drop it and go back to FF. Maybe some day they'll get it together.

                        trenchsol
                        0 0
                        trenchsol

                        9 posts

                          In order to get perfect video playback on Slackware I had to do 3 things:

                          1. Install PepperFlash

                          2. Install extra ffmpeg codecs

                          3. Set and export LD_LIBRARY_PATH variable to directory where ffmpeg.so is located. That should be a directory where Opera is installed. I have a script which does that and runs opera. To check if ffmpeg is found you might run:

                          ldd /usr/bin/opera | grep -i ffmpeg

                          I think there should be a man page for *nix Opera, like there is one for lynx and w3m. These issues should be described there. People should read those man pages, at least briefly. Those who can't be bothered to read man pages at all on UNIX-like operating systems should be ignored and nobody should ever reply to their posts.

                          [Deleted User]
                          0 0
                          Hockey

                          0 posts

                            How long have you guys had the flash problems?

                            jayaguru-shishya
                            0 0
                            jayaguru-shishya

                            65 posts

                              How long have you guys had the flash problems?

                              @tomatoshadow2 Greetings! According to rather a vast review on the post concerning the reported flash problems with Opera[1], they have been around ever since December 2014 - at least.

                              For example, I was able to get Flash running again by following the instructions at the given link (case number #1), but after the latest Opera update (version 44.0.2510.1449), the problem has re-emerged. This even though the Terminal affirms the following:

                              chromium-codecs-ffmpeg-extra is already the newest version (58.0.3029.81-0ubuntu0.16.04.1277).
                              

                              I've been rather patient with Opera on Linux, but I guess I am moving back to Chromium tonight. I wish you good luck solving your Flash problems! ;-)

                              adasiko
                              0 0
                              Dog

                              48 posts

                              • Server monkey

                              How long have you guys had the flash problems?

                              It's not flash problems. It's problems with HTML5 video codecs.

                              jayaguru-shishya
                              0 0
                              jayaguru-shishya

                              65 posts


                                How long have you guys had the flash problems?

                                It's not flash problems. It's problems with HTML5 video codecs.

                                @adasiko Only the Opera browser suffers from these kinds of problems while trying to run Flash content. There ain't such problems with Chromium, for example

                                ocky
                                0 0
                                ocky

                                37 posts

                                • Server monkey



                                How long have you guys had the flash problems?
                                It's not flash problems. It's problems with HTML5 video codecs.

                                @adasiko Only the Opera browser suffers from these kinds of problems while trying to run Flash content. There ain't such problems with Chromium, for example

                                adasiko is right. There are absolutely no problems with flash. Check the h264 problems thread for a solution. Post by blackikeeagle. You may need to repeat the process after Opera browser updates.

                                vincej1657
                                0 0
                                vincej1657

                                9 posts

                                  @ocky - I can't find any thread from blackikeagle. Where is it please ??

                                  ocky
                                  0 0
                                  ocky

                                  37 posts

                                  • Server monkey

                                  The thread https://forums.opera.com/discussion/1882585/h264-problems#Item_6

                                  When you want an easy solution. I'm building ffmpeg.so packages for archlinux for the different opera flavours. Since these are statically linked they should be usable on any linux distribution.

                                  The packages can be found at http://repo.herecura.eu/

                                  You can browse the packagelist where you should be able to find:

                                  opera-ffmpeg-codecs-* opera-beta-ffmpeg-codecs-* opera-developer-ffmpeg-codecs-*

                                  Most of the time the versions are the matching versions where the opera branch was based on. For developer the versions might divert a bit due to issues in the chromium source.

                                  fredyavatar
                                  0 1
                                  fredyavatar

                                  7 posts

                                    Fix video issue on Opera Browser for all Debian Linux Distributions

                                    Ubuntu restricted extras Manual Install

                                    If you are using regular, stock Ubuntu or Debian: sudo apt-get install ubuntu-restricted-extras

                                    If you are using Kubuntu: sudo apt-get install kubuntu-restricted-extras

                                    If you are using Xubuntu: sudo apt-get install xubuntu-restricted-extras

                                    If you are using Lubuntu: sudo apt-get install lubuntu-restricted-extras

                                    jayaguru-shishya
                                    0 0
                                    jayaguru-shishya

                                    65 posts

                                      @ocky @adasiko Did you check the link I gave[1]? Installing the suggested Chrome libs for H.264/MP4 codec does no longer work. Instead, the problem has re-emerged.

                                      @fredyavatar Does the first one work for Ubuntu GNOME 17.04 Zasty Zepus too? As we've all heard the news, Ubuntu will transfer to the GNOME environment as a whole, and Unity desktop won't be developed anymore in the future. Therefore, I've moved to Ubuntu GNOME in advance already :-P

                                      jimunderscorep
                                      0 0
                                      jimunderscorep

                                      127 posts

                                        @fredyavatar I would like to add that the above do NOT apply to debian. There is no package named ubuntu-restricted-extras

                                        @jayaguru-shishya All the *ubuntu-restricted-extras packages install the same stuff and they are not desktop enviroment related, so yes, it will work even if ubuntu switches to gnome.

                                        natasha-from-dnepropetrovsk
                                        0 0
                                        natasha-from-dnepropetrovsk

                                        1 posts

                                          Good afternoon!

                                          This discussion has helped me to obtain mp3 support, https://solus-project.com/forums/viewtopic.php?t=1004 ; post of May 20, 2017 there. I have downloaded an archive with libffmpeg.so file from GitHub (https://github.com/iteufel/nwjs-ffmpeg-prebuilt/releases/tag/0.20.3) and copied the .so-file into /usr/lib64/opera/, previously saving the corresponding old file as libffmpeg.so_orig, restarted Opera and it works.

                                          libffmpeg.so from Chromium didn't help for me. FireFox and Chrome did play content, but Opera didn't.

                                          My OS is openSUSE 42.2, 64-bit.

                                          Regards, Natalia

                                          jimunderscorep
                                          0 0
                                          jimunderscorep

                                          127 posts

                                            As stated on that github repo, that libffmpeg is "FFmpeg prebuilt binaries for NW.js" (nw.js = node-webkit or node.js or electron as it is more commonly known). So, this library is intended for node.js apps like skypeforlinux, popcorntime, vivaldi etc. It just happens to work on opera because both opera and node.js are build on the very same chromium libraries, nothing more, nothing less. It is not the libffmpeg built for chromium or from chromium's source, and that is the reason I will skip that one too :(

                                            But thanks for the tip :)