New Opera Forums launching soon!
Discussion thread

looking for Opera 25 for Mac running 10.6.8 (32-bit)

jlbopera
jlbopera

3 posts

    Hello everyone,

    I did a really stupid thing, and now looking to remedy my problem. I tried to install opera 26 on my aging mac that's stuck on 10.6.8 (because only 32-bit) and it installed w/out complaint - only of course, it doesn't work. So I'd like to find the install for the previous version that worked fine ; the last rendition of opera 25 for mac. When I brows the download section for previous versions of Opera, it seems to only be the Presto versions that are available, nothing found since Opera is running on Blink.

    Any way I can find the last version of Opera 25 Stable for Mac to download ? Any help greatly appreciated !

    Many thanks, Jean-Loup

    10 Replies - 26221 Views

    aeyoun
    1 0
    aeyoun

    169 posts

    • Opera employee
    • Moderator
    • Server monkey
    jlbopera
    0 0
    jlbopera

    3 posts

      Wow, that was fast ! Thank you aeyoun very much for the link ! I really appreciate it !

      jlbopera
      0 0
      jlbopera

      3 posts

        ... installed, and works like a charm. Thanks again !

        nouvopera
        0 0
        nouvopera

        1 posts

          Please where can i find the beta version for mac 10.6.8, i can't find it anywhere?

          thanks

          linuxmint7
          0 1
          linuxmint7

          1344 posts

          • Moderator
          • Server monkey
          • 1000 posts

          Please where can i find the beta version for mac 10.6.8, i can't find it anywhere? thanks

          Here.

          http://net.geo.opera.com/opera/beta/mac?utm_medium=sm&utm_source=desktop_blog&utm_campaign=desktop_side_bar

          aeyoun
          0 0
          aeyoun

          169 posts

          • Opera employee
          • Moderator
          • Server monkey

          Mac OS 10.6 is no longer supported. Please consider upgrading your Mac to a newer operating system version, if supported.

          Any build from before the deprecation notice will still work in OS 10.6.

          fiodepo
          0 0
          fiodepo

          1 posts

            great. I have the very same computer of @jlbopera so for me was a kinda of surprise to discover that v25 was ok. Up to now I was stacked in v12 (meaning that whenever I click for update, the result was "you have the latest version compatible).

            Before doing something wrong can any of you confirm that ftp://ftp.opera.com/pub/opera/desktop/25.0.1614.71/mac/ is suitable for my mac-mini (1.66, early 2006, intelcoreduo, 10.6.8)?

            Thanks

            netpreneur
            0 0
            netpreneur

            1 posts

              Thanks aeyoun - appreciate your help. Found it in google page 1. Laptop with Lion 10.7.5 crashed and Apple store could only restore 10.6.8 so now forced to find a version that works.

              sgunhouse
              0 0
              sgunhouse

              3864 posts

              • Moderator
              • Server monkey
              • 2000 posts
              mandy
              0 0
              mandy

              1 posts

                Hi, I used the link above for old Mac 10.6.8, it is probably me doing something wrong, but I can't get it to set to a UK server, please help

                This discussion has been closed.